Home Search Member List Faq Register Login  
UltimateEditor
Spell as you type not working

Thread Starter: Mohid   Started: 03-31-2008 5:45 PM   Replies: 8
 Karamasoft Support Forums » General Discussions » UltimateEditor » Spell as you type not working
 Printable Version    « Previous Thread   Next Thread »
  31 Mar 2008, 5:45 PM
Mohid is not online. Last active: 4/3/2008 4:47:30 PM Mohid

Top 10 Posts
Joined on 04-01-2008
Posts 7
Spell as you type not working
Can you list what are the comman fix for spell as you type feature in the ultimate editor. I am not quite sure why it is happening. I have gone through the tutorials online and my xml file is correct.

The underline is shows when I type misspelled words in the editor but when I right click on it only show 3 options Cut, Paste, and Copy.

Any clue.


  
  31 Mar 2008, 6:30 PM
Karamasoft is not online. Last active: 10/31/2014 10:34:53 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,695
Re: Spell as you type not working
What browser and operating system are you experiencing this issue on?
  
  31 Mar 2008, 7:16 PM
Mohid is not online. Last active: 4/3/2008 4:47:30 PM Mohid

Top 10 Posts
Joined on 04-01-2008
Posts 7
Re: Spell as you type not working
IE 7
Windows XP Professional Version 2002  Service Pack 2
Does the UtimateEditorInculde needs to in the application root directory? I have it in a seperate directory (not in app root) which I reference.

This is how I have it in the code.

Control:-
<kswc:UltimateEditor ID="UltimateEditor1"   runat="server" 
                TextBoxWidth="98%"  Width="100%" BorderWidth="4" 
                BorderColor="#75b3bd" EditorSource="~/UserControl/ProjectSummaryEditor.xml"  
                DesignTabVisible="false" DesignTabEnabled="false"  HtmlTabEnabled="false" 
                HtmlTabVisible="false" SetFocus="false">
            </kswc:UltimateEditor>


In XMLFile: ProjectSummaryEditor.xml :-
<Toolbar ID="File">
    <ToolbarItem Type="Button" ID="UltimateSpell" Command="UltimateSpell" ButtonFile="UltimateSpell.gif" />
    <ToolbarItem Type="Separator" />
    <ToolbarItem Type="Button" ID="SpellAsYouType" Command="SpellAsYouType" ButtonFile="SpellAsYouType.gif" Selected="true" />
    <ToolbarItem Type="Separator" />
  </Toolbar>

  
  31 Mar 2008, 8:01 PM
Karamasoft is not online. Last active: 10/31/2014 10:34:53 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,695
Re: Spell as you type not working
How do you reference to that UltimateEditorInclude directory? UltimateEditor has IncludeDirectory property, which has a default value of "~/UltimateEditorInclude". If you don't want to have UltimateEditorInclude directory under your web app, you have to set IncludeDirectory of your UltimateEditor control properly to point to your include directory.
  
  31 Mar 2008, 8:23 PM
Mohid is not online. Last active: 4/3/2008 4:47:30 PM Mohid

Top 10 Posts
Joined on 04-01-2008
Posts 7
Re: Spell as you type not working
I have created a dll which resides in the bin directory of the project. I added a reference to that dll using the add reference in Project Properties in Visual Studio 2008.

Do you think that (reference) could be the issue that is causing problems with spell as you type feature?

I do not  have UltimateEditorInclude directory in my application root. So if I understand you correctly I have to set the reference correctly for my include directory. I think, that is how I have it and it should be correct.

Just to be clear it is not mandatory to have it in the application root or is it?


This is what I have in ascx control

<%@ Register assembly="UltimateEditor" namespace="Karamasoft.WebControls.UltimateEditor" tagprefix="kswc" %>


  
  31 Mar 2008, 8:27 PM
Karamasoft is not online. Last active: 10/31/2014 10:34:53 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,695
Re: Spell as you type not working
You also need to have UltimateSpellInclude folder under your app root just like UltimateEditorInclude.
  
  31 Mar 2008, 8:39 PM
Mohid is not online. Last active: 4/3/2008 4:47:30 PM Mohid

Top 10 Posts
Joined on 04-01-2008
Posts 7
Re: Spell as you type not working
I have both, UltimateSpellInclude and UltimateEditorInclude.


  
  02 Apr 2008, 1:55 PM
Karamasoft is not online. Last active: 10/31/2014 10:34:53 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,695
Re: Spell as you type not working
It was caused by multiple editors on one page. Fixed the issue and sent you the new JS files in a separate email.
  
  02 Apr 2008, 3:28 PM
Mohid is not online. Last active: 4/3/2008 4:47:30 PM Mohid

Top 10 Posts
Joined on 04-01-2008
Posts 7
Re: Spell as you type not working
It seems to be working now. Thanks.

  
 Page 1 of 1 (9 items)
Karamasoft Support Forums » General Discussions » UltimateEditor » Spell as you type not working

You can add attachments
You can post new topics
You can reply to topics
You can delete your posts
You can edit your posts
You can create polls
You can vote in polls
Forum statistics are enabled
Forum is unmoderated

© 2002-2014 Karamasoft LLC. All rights reserved.