Home Search Member List Faq Register Login  
UltimateEditor
Re: AutoCorrect is enabled even when it's set to false

Thread Starter: pivko4life   Started: 10-31-2007 12:03 PM   Replies: 16
 Karamasoft Support Forums » General Discussions » UltimateEditor » Re: AutoCorrect is enabled even when it's set to false
 Printable Version    « Previous Thread   Next Thread »
  31 Oct 2007, 12:03 PM
pivko4life is not online. Last active: 11/24/2013 9:38:19 PM pivko4life

Top 10 Posts
Joined on 10-10-2007
Posts 32
AutoCorrect is enabled even when it's set to false
Hi,

I am using UltimateEditor control on a form with UltimateSpell control and I have AutoCorrect property set to False and SpellAsYouType set to True.  However, when I start typing something with many mistakes, it automatically corrects them.  I already tried setting the AutoCorrect property in codebehind and it still corrects the mistakes.  Here is the my code for the controls.


<cc1:UltimateEditor id="UltimateEditor1" runat="server" HtmlTabVisible="False" HtmlTabEnabled="False"
          DisplayWordCount="False" DisplayCharCount="False" UltimateSpellID="UltimateSpell1" DesignTabEnabled="False"
          DesignTabVisible="False"></cc1:UltimateEditor>
         <cc2:UltimateSpell id="UltimateSpell1" runat="server">
          <MisspelledWordStyle Font-Bold="True" ForeColor="Red"></MisspelledWordStyle>          
         </cc2:UltimateSpell> 






public class EditRichText : System.Web.UI.Page

{

protected System.Web.UI.HtmlControls.HtmlInputHidden hRichText;

protected Karamasoft.WebControls.UltimateEditor.UltimateEditor UltimateEditor1;

protected Karamasoft.WebControls.UltimateSpell.UltimateSpell UltimateSpell1;

protected bool bUpdate;

private void Page_Load(object sender, System.EventArgs e)

{

UltimateSpell1.ControlIdsToCheck = UltimateEditor1.TextBoxID;

UltimateSpell1.AutoCorrect = false;

UltimateSpell1.SpellAsYouType = true;

UltimateSpell1.ShowSpellButton = false;

}

}



  
  31 Oct 2007, 12:56 PM
Karamasoft is not online. Last active: 5/8/2018 10:36:45 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,820
Re: AutoCorrect is enabled even when it's set to false
AutoCorrect must be false by defailt. Could you remove the following line where you set it to false explicitly:

UltimateSpell1.AutoCorrect = false;

Please tell us whether this makes any difference.


  
  31 Oct 2007, 1:00 PM
Karamasoft is not online. Last active: 5/8/2018 10:36:45 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,820
Re: AutoCorrect is enabled even when it's set to false
We tried your code and couldn't reproduce the problem. For example, we typed the word cleanlyness (which has only one suggestion) and it did not auto-correct it. Are you using the latest version?
  
  31 Oct 2007, 1:16 PM
pivko4life is not online. Last active: 11/24/2013 9:38:19 PM pivko4life

Top 10 Posts
Joined on 10-10-2007
Posts 32
Re: AutoCorrect is enabled even when it's set to false

removing line UltimateSpell1.AutoCorrect = false; did not make any difference.  Let me clarify something, it only reacts (corrects mistakes) when i'm trying to type a large amount of misspelled words, just by pressing any keys that i feel like.  It reacts especially when i create bullets or numbers.

This is what i'm trying to type:

 

  1. thisdhke mkewli shj,e m
  2. klsjeihhfd,me ihsdk
  3.  wherim,djirelk
  4. w;dklkfl.  2 josek,dlfkeojf.
  5. wjeofdl;sk ldkofe  lkauozjemzlkjwojhd.
  6. fdkljfkdfmd,.s
  7. dslkke kljeli jdlkkk ldjj
  8. l;slkf ldkfe.djjf
  9. fkdfj

I am satisfied with UltimateEditor for underlining misspelled words, but the editor should not be changing anything the users type by itself.  By the way, while typing in this message, the editor did not correct any of my errors.  Maybe you guys can send me the code for it, so i can change mine as an example.


  
  31 Oct 2007, 1:36 PM
Karamasoft is not online. Last active: 5/8/2018 10:36:45 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,820
Re: AutoCorrect is enabled even when it's set to false
For fast typers, we added a property called SpellWaitPeriod. It allows you to specify the wait period in milliseconds before sending a spell check request to server. If the user waits without typing for this amount of time it starts the spell check process. Default is 300, and minimum is 100.

If you are typing too fast, you might want to set SpellWaitPeriod to 100.

You can also try not using editor max character and word count functionality since they process every key stroke and reduce the performance. You can set DisplayCharCount and DisplayWordCount properties of your UltimateEditor to False.

This Forums system does not use SpellAsYouType functionality.

  
  31 Oct 2007, 2:44 PM
pivko4life is not online. Last active: 11/24/2013 9:38:19 PM pivko4life

Top 10 Posts
Joined on 10-10-2007
Posts 32
Re: AutoCorrect is enabled even when it's set to false
DisplayCharCount and DisplayWordCount properties of UltimateEditor are already set to False.  When I set StillWaitPeriod to 100 the problem intensified, causing the UltimateSpell to change mistakes more noticably.  However, when I turn off SpellAsYouType functionality, nothing gets changed no matter how many mistakes I have.   Can you try to reproduce the error by setting the same property and SpellWaitPeriod=100 and typing random characters in the editor.  I just want to make sure if my setting are causing this issue or it's a bug in SpellAsYouType functionality.
  
  31 Oct 2007, 2:53 PM
Karamasoft is not online. Last active: 5/8/2018 10:36:45 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,820
Re: AutoCorrect is enabled even when it's set to false
Unfortunately we cannot reproduce the issue in our test system on your sample code and setting SpellWaitPeriod to 100. Can you reproduce the issue with the sample on our website at http://www.karamasoft.com/Samples.aspx?component=UltimateSpell by changing the SpellWaitPeriod dropdown value to 100?
  
  31 Oct 2007, 3:00 PM
pivko4life is not online. Last active: 11/24/2013 9:38:19 PM pivko4life

Top 10 Posts
Joined on 10-10-2007
Posts 32
Re: AutoCorrect is enabled even when it's set to false
Yes, I am able to reproduce the issue in your sample application as well.  All I am doing is typing random characters and putting spaces so the spellcheck recognizes them as words and every once in a while i hit return key to start a new line.  It even changed some mistakes to what appears to be a part of a tag:

class=SpellErrorCssClass Suggestions="" ErrorType="0">


  
  31 Oct 2007, 3:12 PM
Karamasoft is not online. Last active: 5/8/2018 10:36:45 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,820
Re: AutoCorrect is enabled even when it's set to false
This migth be related to your internet connection speed (since the spell checking is done by making AJAX requests to the server) or the browser/operating system version you are using since we cannot reproduce it on that sample in our test environment.
  
  31 Oct 2007, 3:24 PM
pivko4life is not online. Last active: 11/24/2013 9:38:19 PM pivko4life

Top 10 Posts
Joined on 10-10-2007
Posts 32
Re: AutoCorrect is enabled even when it's set to false
I am using IE6 on Windows 2000 Server.  This issue occurs on my local machine, on another Windows 2003 Server, and your sample application which is located on your site so my internet connection speed is not an issue in this case. 

How many lines or random characters did you try?  Try putting in more then 3 lines of characters, separating every 10 characters with a space and every 7-8 words with a new line. 

  
  31 Oct 2007, 3:37 PM
Karamasoft is not online. Last active: 5/8/2018 10:36:45 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,820
Re: AutoCorrect is enabled even when it's set to false
We tried at least 20 lines with the number of characters you described but still cannot see it. Maybe we are missing something here. It just doesn't change the word you type but underline the words if there is a spelling error. Do you have some other programs running on your machine at the same time you are testing such as anti-virus program, anti spyware, etc that might interfere with the spell checking behind-the-scenes?
  
  31 Oct 2007, 4:00 PM
pivko4life is not online. Last active: 11/24/2013 9:38:19 PM pivko4life

Top 10 Posts
Joined on 10-10-2007
Posts 32
Re: AutoCorrect is enabled even when it's set to false
No, I actually dont have any antivirus software nor anti-spyware installed on this virtual machine.  I am also experiencing rare cases when the red underlining of mistakes becomes fatter for some words, as if the word is being underlined twice.   And in some cases, after a while SpellAsYouType stops any underlining and just gives up.  It appears to be an issue with SpellAsYouType functionality, since it's not happening when SpellAsYouType is turned off.  However, I already demonstrated to my users all the cool features of UltimateEditor and SpellAsYouType feature was the one that they liked the most, so it would be cruel for me to turn it off and they would probably complain.   But I guess they would complain more if the editor was changing something that they wrote by itself.  Let me know if you have any ideas, hopefully we'll be able to conquer this problem.  Thanks for your help.
  
  31 Oct 2007, 4:09 PM
Karamasoft is not online. Last active: 5/8/2018 10:36:45 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,820
Re: AutoCorrect is enabled even when it's set to false

Could it be your virtual machine instance making the spell checking process slower? Have you tested SpellAsYouType functionality without a virtual machine?


  
  31 Oct 2007, 4:33 PM
pivko4life is not online. Last active: 11/24/2013 9:38:19 PM pivko4life

Top 10 Posts
Joined on 10-10-2007
Posts 32
Re: AutoCorrect is enabled even when it's set to false

Let me clarify something, there is no issue with spell checking process being slow, it's actually quite fast.  The problem occurs when I start typing randomly and  spellcheck changes the words that I type, usually by removing spaces, placing the cursor somewhere in the middle of the paragraph and then back to the end, or adding some words that appear to be a part of some tag.  I use virtual machine to write code locally but then I move my files to a dev server.  I've tested this issue on the dev site as well and i'm experiencing the same problem.   


  
  31 Oct 2007, 5:25 PM
Karamasoft is not online. Last active: 5/8/2018 10:36:45 AM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,820
Re: AutoCorrect is enabled even when it's set to false
So it is not caused by virtual machine then. As we mentioned in one of our previous posts, UltimateSpell does the spell checking through AJAX callbacks. When SpellAsYouType is set to True, the new (and updated) words that are typed are sent to spell checker (which lives on the server-side) periodically based on SpellWaitPeriod value. It is not that spell checking process is slow but the request to the server for the spell checking and getting the response back might be slow and might cause you to lose some words you typed before you get the response from the server if the response is slow. Are you using the latest version by the way? Since you experienced the problem even with the sample on our website, this question migth not be any help. Sorry for any inconvenience.
  
 Page 1 of 2 (17 items) 1 2 »
Karamasoft Support Forums » General Discussions » UltimateEditor » Re: AutoCorrect is enabled even when it's set to false

You can add attachments
You can post new topics
You can reply to topics
You can delete your posts
You can edit your posts
You can create polls
You can vote in polls
Forum statistics are enabled
Forum is unmoderated

© 2002-2021 Karamasoft LLC. All rights reserved.