Home Search Member List Faq Register Login  
UltimateEditor
Re: Invalid XML tags when copy content from word to KaramaSoft.UltimateEditor

Thread Starter: akspatel   Started: 10-01-2015 8:49 AM   Replies: 1
 Karamasoft Support Forums » General Discussions » UltimateEditor » Re: Invalid XML tags when copy content from word to KaramaSoft.UltimateEditor
 Printable Version    « Previous Thread   Next Thread »
  01 Oct 2015, 8:49 AM
akspatel is not online. Last active: 10/1/2015 8:54:49 AM akspatel



Top 10 Posts
Joined on 10-21-2013
Posts 18
Invalid XML tags when copy content from word to KaramaSoft.UltimateEditor
Hello,
We are using KaramaSoft.UltimateEditor allowing users input or pastes content on KaramaSoft.UltimateEditor control from asp.net web page and back-end we are using Aspose.word to generate consolidated word document for users.

We are using UltimateEditor.dll version 3.7.5142.33388 with asp.net visual studio 2010.

We are facing issue of pasting content on KaramaSoft.UltimateEditor and display full content but when document generated with aspose.word, part is missing.

Example,

(A) We copy following content in KaramaSoft.UltimateEditor from Microsoft Word document

3) Inadequate segregation of duties in the process to aggregate and estimate the CCAR buffer
The roles and responsibilities over the CCAR inherent model risk aggregation are not properly segregated. The Model Risk Analytics group (reporting to the head of Model Risk Management Team) aggregates the stand-alone inherent model risk charges from the operational units, runs the Aggregation model and assesses the results. While the aggregation model meets AIG’s criteria for a “model”, it has not been registered in Model Administration and Reporting System (MARS) and therefore not validated. However, under AIG’s current model risk management policy, the model would need to be validated by the Independent Validation Group (reporting to the head of Model Risk Management Team) which could lead to a potential conflict of interest.

As a result, the capital buffer results may not include all relevant components.

(B) Content display as pasted on UltimateEditor, when viewed generated XML have invalid tag. Check first p tag invalid attribute. Also no closing tags for <br>

<p 0pt;??="" 0in=""><span style="font-size: 10pt;"><br>&nbsp;</span><b><span style="font-size: 10pt;">3) </span></b><span style="font-size: 10pt;">Inadequate segregation of duties in the process to aggregate and estimate the CCAR buffer<br></span></p> <span style="font-size: 10pt;">The roles and responsibilities over the CCAR inherent model risk aggregation are not properly segregated. The Model Risk Analytics group (reporting to the head of Model Risk Management Team) aggregates the stand-alone inherent model risk charges from the operational units, runs the Aggregation model and assesses the results. While the aggregation model meets AIG’s criteria for a “model”, it has not been registered in Model Administration and Reporting System (MARS) and therefore not validated. However, under AIG’s current model risk management policy, the model would need to be validated by the Independent Validation Group (reporting to the head of Model Risk Management Team) which could lead to a potential conflict of interest. <br> <br> </span><span style="font-size: 10pt;">As a result, the capital buffer results may not include all relevant components.</span>

(C) when generated word document using Aspose.Word displaying only first line and missing last two paragraph as below

3) Inadequate segregation of duties in the process to aggregate and estimate the CCAR buffer

(D) I manually corrected the XML and Aspose displayed content correctly.

Please suggest how KaramaSoft could generate valid XML tags or remove invalid XML tags.

Also, could you suggest back-end editor to generate valid word document?

Thank you
Akshay Patel


  
  01 Oct 2015, 8:58 PM
Karamasoft is not online. Last active: 11/10/2017 3:24:14 PM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,818
Re: Invalid XML tags when copy content from word to KaramaSoft.UltimateEditor
You need to use the XHTML mode of the editor. Please refer to the XHTML Output live demo sample at https://www.karamasoft.com/Samples.aspx?component=UltimateEditor&sample=XHTMLOutput and click on Show Code link at the bottom of the page to see the code.
  
 Page 1 of 1 (2 items)
Karamasoft Support Forums » General Discussions » UltimateEditor » Re: Invalid XML tags when copy content from word to KaramaSoft.UltimateEditor

You can add attachments
You can post new topics
You can reply to topics
You can delete your posts
You can edit your posts
You can create polls
You can vote in polls
Forum statistics are enabled
Forum is unmoderated

© 2002-2018 Karamasoft LLC. All rights reserved.