Home Search Member List Faq Register Login  
UltimateMenu
Re: Chrome

Thread Starter: LKC   Started: 08-18-2010 12:16 AM   Replies: 3
 Karamasoft Support Forums » General Discussions » UltimateMenu » Re: Chrome
 Printable Version    « Previous Thread   Next Thread »
  18 Aug 2010, 12:16 AM
LKC is not online. Last active: 8/1/2011 10:22:14 AM LKC

Top 10 Posts
Joined on 10-31-2008
Posts 24
Chrome
The Menu doesn't appear to function in Google Chrome after upgrading the website to .NET 4.0. 

I have noticed the following:

1.  The javascript is not written to the page. 
  • Javascript is missing from the bottom of the page
  • onmouseout, onmouseover, and onclick events are missing in the menu <td>.
2.  The Div is missing the ID

3.  Has links inside the TD instead of onclick. 

4.  Doesn't have any sub menu items.


All the links in the menu have uTB=#  where # appears to be the id field from the table.  I don't know why it is appending this to the end.

I have other sites running a previous version of .NET and they are working fine in Chrome.

Any help you could provide would be greatly appreciated. 





  
  23 Aug 2010, 11:14 PM
Karamasoft is not online. Last active: 11/10/2017 3:24:14 PM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,818
Re: Chrome
The browser definition for Chrome might be missing from your machine.config file after the installation. You can compare the machine config files for .NET 3.5 and 4.0 and add the necessary settings for Chrome to your .NET 4.0 machine.config file. Please refer to http://msdn.microsoft.com/en-us/library/ms228122.aspx to learn more about browser definition file schema.
  
  19 Dec 2010, 3:04 PM
LKC is not online. Last active: 8/1/2011 10:22:14 AM LKC

Top 10 Posts
Joined on 10-31-2008
Posts 24
Re: Chrome
We have looked at this and are unable to correct it.  I'm curious if you have Ultimate Menu running under .NET 4 and if it is having similar problems.  If you do have it running under .NET 4 and it is working can you please provide the settings in the machine config file?

I've tried this on several computers and servers (Windows 7/Windows 2008/Windows Vista) and no success with any of the changes.  This is starting to be a real problem.

Thank you

  
  03 Jan 2011, 10:53 PM
Karamasoft is not online. Last active: 11/10/2017 3:24:14 PM Karamasoft

Top 10 Posts
Joined on 09-05-2004
Posts 6,818
Re: Chrome
We did some research on this and found the following article: http://weblogs.asp.net/ricardoperes/archive/2009/09/22/detecting-chrome-browser-in-asp-net.aspx
You might want to try it in your test environment to see if it resolves the issue.

  
 Page 1 of 1 (4 items)
Karamasoft Support Forums » General Discussions » UltimateMenu » Re: Chrome

You can add attachments
You can post new topics
You can reply to topics
You can delete your posts
You can edit your posts
You can create polls
You can vote in polls
Forum statistics are enabled
Forum is unmoderated

© 2002-2018 Karamasoft LLC. All rights reserved.